Zabbix 3.4 integration - permission denied

Hi team,

I have configured Zabbix integration. Test event with PagerDuty agent can be sent out but not with Zabbix alert.

PagerDuty log doesn’t show related problem.
Zabbix Action log shows “OSError: [Ernno 13] Permission denied: '/var/lib/pdagent/outqueue/tmp/xxxxx.txt'

I granted my Zabbix user permission to/var/lib/pdagent and even /varl/lib/pdagent/outqueue/tmp but still no luck.

Which user should have permission to that folder?

Hi Stephane,

This appears to be issue with permissions still.

Can I point you to our troubleshooting guide for insights on dealing with this.

Thanks

Hi Chiedu,

Thanks for your reply. I already went through the troubleshooting guide but still no luck.

Troubleshooting Issues with the Agent-based Integration
Verify the Agent is installed > yes
Verify the Agent is Running > yes
Check the Agent’s Logs for Errors > no error related to the permission issue
Trigger a Test Incident with the Agent’s CLI > working fine
Trigger a Test Incident with pd-zabbix > working fine

My Zabbix AlertScriptsPath is in /usr/lib/zabbix/alertscripts
/usr/lib/zabbix/alertscripts/pd-zabbix has execute permissions

ls -l /usr/lib/zabbix/alertscripts/
total 0
lrwxrwxrwx. 1 root root 45 Apr 25 17:09 pd-zabbix -> /usr/share/pdagent-integrations/bin/pd-zabbix

I still receive the permission denied error in Zabbix Action log.

ls -l /var/lib/pdagent/outqueue/
total 0
drwxrwx---. 2 pdagent zabbix   6 Aug 14  2018 err
drwxrwx---. 2 pdagent zabbix   6 Apr 30 09:43 pdq
drwxrwx---. 2 pdagent zabbix 128 Apr 30 09:43 suc
drwxrwx---. 2 pdagent zabbix  22 Apr 30 09:43 tmp

Hi Stephane,

Please can you confirm that the Zabbix PagerDuty group have read access to the services/hosts that should have triggered events?

Also that SELinux is disabled as that could interfere with the script being executed.
To do this:

  1. Edit /etc/selinux/config using your preferred text editor

  2. Update SELINUX=enforcing to be SELINUX=disabled

  3. Restart your system

  4. Attempt to trigger a test incident in PagerDuty through Zabbix.

Thanks.

Hi Chiedu,

Disabling SELinux fixed the permission issue.

Thanks!

Hi Stephane,

Many thanks for letting me know.

I will be closing this post now.

Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.