Volume override does not work when phone is on Vibrate

questions
android

(Chris Smith) #1

The app seems to only override my phone’s volume settings when my phone is set to Do Not Disturb. When I have it set to Vibrate, Pager Duty will not make a noise.

My phone is a OnePlus 5T running android 8.1.0.

The physical toggle is incredibly easy to switch to Vibrate instead of Do Not Disturb. I need Pager Duty to always make a loud noise regardless of what setting the phone is one.

Is there a setting I am missing or a way to work around this issue?

Thanks


(geeth) #3

Hey Chris,

Android does not provide the ability to make exceptions mode and support exceptions when the phone is on Do Not Disturb mode.

A work-around though not very typical would be to allow vibrations of notifications during the DND mode and which would then allow PagerDuty to notify you with sound as well.

With the OnePlus 5T, the alert slider has the capability to toggle to ring, silent and vibrate so I could understand why you would want this feature supported.

Hopefully, with the Android 9 update coming to your phone, there would be better options into customizing your alert slider.


#4

I’m on android 9 (pixel 3), and when I first added pagerduty, the alerts did not get through vibrate mode, which was to be expected. Then I set the override system volume, and alerts are now blaring through as expected through silent/dnd/vibrateonly modes. however, now I turned off the override system volume, and the alerts are still blaring through all the quiet modes even though it should no longer be overriding the system volume. is this a bug?

There’s like no way to silence my pagerduty anymore short of just deleting the app. I sure as heck am not comfortable walking into a movie theater in its current state.


(David Hills) #5

I have the same problem as willy above - my Android phone (Samsung Galaxy S8) is sounding PagerDuty alerts at a high volume even when the phone is set to vibrate only. I previously used the ‘Override system volume’ mode but have had that turned off for a while now.

@willy - the far from ideal workaround that I’m using at the moment is to set my phone to ‘Aeroplane mode’ when I need it to be truly silent, so that PagerDuty alerts don’t come through at all.