nagios integration webhook does not work

Hi there,

I have followed the guide and get the nagios => pager duty working.

The web hook part does not. There are some annoyances as well.

First in the pagerduty web gui when I added the Nagios extension I no longer be able to remove it or even edit it.

Secondly, I have no way to know which protocol that pager duty to talk back to nagios server, http? or https, as the config only allows the root url and no documentation stating what it is

Then thirdly, seems the web hook does not work. I route the cgi url to nginx which reverse proxy to the nagios server and I did not see any request coming from pagerduty at all while testing. Admit that because point 2. I assume pagerduty use https which it should as I have to enter the user and password. and port 80 is not open.

I am not sure if I open port 80 it goes but I am very reluctant to open that port and sending user/password from pagerduty to nagios at all.

Hi Steve,

Checking in here to refer you to the ticket that we have open with you from PagerDuty Support! Please let us know if this helps:

Is the Nagios Core server accessible over the internet to receive webhook calls from PagerDuty? If it is not, you would want to whitelist PagerDuty’s IPs.

Also you may want to review our troubleshooting guide for possible solutions to this issue. I hope this helps.

And dont tell me the similar trouble shooting thing and whitelist, we dont want to do that based on our situation.

We want:

  • be able to remove the extenstion in the GUI and add new one. If someone actually do test of the usage you will see what I reported. Flaky and unreliable - Tested on chrome browser and firefox.

  • be documented the protocol it posts back and make sure it works the way it is designed.

so user can design their infrastructure the way they want to make it work. For my case I expose one cgi part via nginx reverse proxy - in theory it should work but it does not and PagerDuty even does not even send any data.

Is it too hard to verify these things above?

Hi @stevek! You should be able to edit or remove your Nagios webhooks by going to the Integrations tab of the service in PagerDuty. Under the Extensions section, click the cog (:gear:) icon to the right of your Nagios extension to see these options.

If you don’t see this option, this could be due to your permissions in PagerDuty. If you’re still stuck, please send us an email at support@pagerduty.com with a link to the service in question, and we’d be happy to take a closer look.

Regarding your question around which protocol webhooks to Nagios uses, it will attempt to use https first, and if that fails, http will be used. Thus, only the root URL should be entered in. From our Nagios integration guide:

For the Extension Type select Nagios , then enter in a Name for your webhook, paste in your Nagios Username , Password and Root URL , and click Save . The URL will look similar to this: ip-or-domain/nagios3/cgi-bin/pagerduty.cgi . Do not include http:// or https:// .

Thanks but I read form the Nagios extension saying that I should not have the protocol in the settings, - only need the root url. That is why it comes to question.

This is not web hook API v2 or v2 at all - ti is nagios extensions.

I tried to setup again yesterday but no luck. It seems no traffic coming in. However I did try to use generic web hook v1 using https and traficx comes it but the problem si I have to trigger it to a middleware first to translate and proxy it to the form nagios is expecting and I have not make that layer yet, I dont want to use external servire like pastedb etc …

seems too much about little thing really to make it work, it should not that hard for Pager Duty to review the nagios post back extensions.

Thanks

Hi @stevek,

Yes, you’re correct - you should not include the HTTPS or HTTP protocol in the extension URL.

That being said, could you please provide more context on how these alerts are being sent to Nagios? Is your Nagios server on a private ip address? If so, then webhook calls cannot be made to a private ip address.

If you would like us to review your configuration, please feel free open up a ticket by sending an email to support@pagerduty.com.

Thanks,