How to get noisy notifications on Android Pie while rest of phone is silenced?

questions

(Manoj) #1

I have a Pixel 3 with latest Android Pie and the November security update. I have a Pixel 2 and 1 as backups that have had the PagerDuty app for a year or two as well. It seems like recent updates to something have broken the ability to get noise from notifications from PagerDuty while the rest of the phone is in Do Not Disturb mode. Google hasn’t helped matters, but I used to have this working even Pie, but now, sending test notifications from the webapp is not making noise on the phone. What do I need to have notifications make noise in tests and for production alerts? I need this to wake me up without having random chat noises doing so.

Thanks.


(Chris Dryden) #2

Hi Manoj,

Are you able to confirm what version of the PagerDuty app you are using currently?


(Manoj) #3

Latest version all around. 5.28.1 on all devices.

I think that the test push notifications are testing low urgency notifications so that they don’t test the high urgency noises.

Oddly enough, after synchronizing setting on all three devices to rule out any weirdness, and creating a custom service pointing specifically to me to force a high urgency notification, my Pixel 3 is generating noise but the 2, 1, and C (running 8.1) aren’t.

DND is turned on for all of them in the OS. There used to be an “override DND” setting in the OS somewhere but I can’t find it anymore. “Override system volume” used to take me to a permission screen listing apps that can do so, but doesn’t list PagerDuty in the list anymore. The options I have set in the app are:

Vibration: enabled
Override System Volume: enabled
Clear Notifications: enabled
Push Notifications Status: enabled
Live Updating: enabled


(Manoj) #4

OK, I think I figured out how to make this work, though I don’t know how it got screwed up in the first place. Combinations of Android and PagerDuty changing behavior over the past year without my having found clear documentation have made this more confusing.

Under each notification channel/category in system app notification settings for PagerDuty, that’s where you find the “Override Do Not Disturb” option. It was on for my Pixel 3 and off for my other devices for some reason, with me having made no relevant changes on my end that I know of.