Android Pie notifications ignoring Do Not Disturb

questions

(Stuart Brown) #1

I am currently running Android Pie with the latest security updates on a Pixel 2.

On my phone, with PagerDuty 5.27 if I put my phone in to Do Not Disturb mode, notifications still come through at absolute minimum volume and vibrate until I block notifications from being displayed in the application notifcation settings.

This was similar to a bug in earlier versions of Pagerduty on Oreo 8.1 with PagerDuty 5.22.1 where notifications will still alert when set to anything other than total silence.


(John O'Donnell) #2

HI Stuart,

Thanks for your message. Can you tell me if you had the Override sound configured in the notification settings? If so, the reason this may be happening is that when Override is turned off, the app switched to use the phones Alarm tone levels to notify which may explain why you are being notified even with the notifications sound off.

Check this out, let me know what you think.

John


(Stuart Brown) #3

I’ll try that, but then that means I also have to disable alarms for Do Not Disturb which is not what I want to do because then I can’t use Do Not Disturb to silence applications and keep phone alarms.


(Paul) #4

The latest version of the PagerDuty app changed the way Do Not Disturb works on Android 8 and 9 devices. We recently updated our Knowledge Base article on overriding Do Not Disturb with instructions.

For Android 8 (Oreo) and Android 9 (Pie), you can override Do Not Disturb by going to your phone settings (outside of the PagerDuty app) > Apps & notifications > PagerDuty > Notifications . Here you should see an option to turn on high and low urgency notifications.

If this doesn’t help, there are a few other troubleshooting steps in that Knowledge Base article as well - hopefully that helps!


#5

Hi, I can confirm that this behaviour looks like a bug or at least some change comparing to previous versions / android oreo. I’m on android pie and have “override system volume” turned off in application settings. When I switch the system sound to vibration only or silent the notification sound is not muted. It seems that app ignores current system volume level.


(Stuart Brown) #6

Yes, the problem here is the opposite to the Knowledge Base article. From what I was reading, the knowledge base article seems to suggest that Override System Volume is to enable PagerDuty to still alert even when the phone is set to silent.

What I am seeing is that there is NO way other than to block notifications for PagerDuty to actually have PagerDuty follow every other application on my mobile to NOT make a sound when Do Not Disturb is enabled and “Override System Volume” is disabled.


(John O'Donnell) #7

HI all,

Sorry for the ongoing disruption here, however In the coming days we will be releasing an update for the app. Sorry you have had to hold out until now to get an update, but we hope this will resolve things.

Let me know if you have any additional questions in the meantime.

John


(Paul) #8

We have now released an update to the PagerDuty app to fix the push notification behavior to use the ring volume again instead of the alarm volume.

In addition to updating push notification behavior, this update also includes improvements to schedules and overrides in the mobile app.

Thank you for bringing this to our attention and for your patience as we worked to address this.


(system) #9

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.